Legacy Node API Allows Impersonation in github.com/spiffe/spire/pkg/server/endpoints/node
CVE-2021-27098GHSA-h746-rm5q-8mgq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/spiffe/spire 0.12.1, 0.11.3, 0.10.2, 0.9.4, 0.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.8.1, < 0.8.5>= 0.9.0, < 0.9.4>= 0.10.0, < 0.10.2>= 0.11.0, < 0.11.3>= 0.12.0, < 0.12.1
- Fixed in
- 0.8.5, 0.12.1, 0.9.4, 0.11.3, 0.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h746-rm5q-8mgq lists affected ranges: Go github.com/spiffe/spire >=0.8.1 =0.9.0 =0.10.0 =0.11.0 =0.12.0 <0.12.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-27098: 0.56% estimated exploitation activity in the next 30 days; percentile 46.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In SPIRE 0.8.1 through 0.8.4 and before versions 0.9.4, 0.10.2, 0.11.3 and 0.12.1, specially crafted requests to the FetchX509SVID RPC of SPIRE Server’s Legacy Node API (github.com/spiffe/spire/pkg/server/endpoints/node) can result in the possible issuance of an X.509 certificate with a URI SAN for a SPIFFE ID that the agent is not authorized to distribute. Proper controls are in place to require that the caller presents a valid agent certificate that is already authorized to issue at least one SPIFFE ID, and the requested SPIFFE ID belongs to the same trust domain, prior to being able to trigger this vulnerability. This issue has been fixed in SPIRE versions 0.8.5, 0.9.4, 0.10.2, 0.11.3 and 0.12.1. What are the changes introduced by the patched versions? The changes introduced to address this issue are related to enforcing that the FetchX509SVID RPC of SPIRE Server’s Legacy Node API only issues X.509 certificates with SPIFFE IDs that the agent is authorized to distribute.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h746-rm5q-8mgq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-27098 Advisory: Legacy Node API Allows Impersonation in github.com/spiffe/spire/pkg/server/endpoints/node IDs: CVE-2021-27098, GHSA-h746-rm5q-8mgq Record: https://patchnext.com/advisories/cve-2021-27098 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/spiffe/spire 0.12.1, 0.11.3, 0.10.2, 0.9.4, 0.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/spiffe/spire: affected >= 0.8.1, < 0.8.5; >= 0.9.0, < 0.9.4; >= 0.10.0, < 0.10.2; >= 0.11.0, < 0.11.3; >= 0.12.0, < 0.12.1; fixed in 0.8.5, 0.12.1, 0.9.4, 0.11.3, 0.10.2 ## Suggested inspection (read-only) - Go github.com/spiffe/spire: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/spiffe/spire. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h746-rm5q-8mgq (GitHub-reviewed advisory GHSA-h746-rm5q-8mgq lists affected ranges: Go github.com/spiffe/spire >=0.8.1 =0.9.0 =0.10.0 =0.11.0 =0.12.0 <0.12.1) Commands are suggestions: review each one before running it.
Loading voting…