fast-xml-parser vulnerable to Prototype Pollution through tag or attribute name
CVE-2021-26920GHSA-x3cc-x39p-42qx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-xml-parser 4.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-xml-parser
- Affected
- < 4.1.2
- Fixed in
- 4.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x3cc-x39p-42qx lists affected ranges: npm fast-xml-parser >=0 <4.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-26920: 9.50% estimated exploitation activity in the next 30 days; percentile 95.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
- CVE-2023-26920: 1.15% estimated exploitation activity in the next 30 days; percentile 66.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact As a part of this vulnerability, user was able to se code using `proto` as a tag or attribute name. ```js const { XMLParser, XMLBuilder, XMLValidator} = require("fast-xml-parser"); let XMLdata = " hacked " const parser = new XMLParser(); let jObj = parser.parse(XMLdata); console.log(jObj.polluted) // should return hacked ```
Patches The problem has been patched in v4.1.2
Workarounds User can check for "proto" in the XML string before parsing it to the parser.
References https://gist.github.com/Sudistark/a5a45bd0804d522a1392cb5023aa7ef7
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GHSA-x3cc-x39p-42qx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-26920 Advisory: fast-xml-parser vulnerable to Prototype Pollution through tag or attribute name IDs: CVE-2021-26920, GHSA-x3cc-x39p-42qx Record: https://patchnext.com/advisories/cve-2021-26920 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-xml-parser 4.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-xml-parser: affected < 4.1.2; fixed in 4.1.2 ## Suggested inspection (read-only) - `npm ls fast-xml-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-xml-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x3cc-x39p-42qx (OSV record GHSA-x3cc-x39p-42qx lists affected ranges: npm fast-xml-parser >=0 <4.1.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…