Skip to content

← Actionable
High, CVSS 8.7amended

markdown2 Regular Expression Denial of Service

CVE-2021-26813GHSA-jr9p-r423-9m2r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (markdown2 2.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI markdown2

    Affected
    >= 1.0.1.18, < 2.4.0
    Fixed in
    2.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-26813: 2.32% estimated exploitation activity in the next 30 days; percentile 83.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

markdown2 =1.0.1.18, fixed in 2.4.0, is affected by a regular expression denial of service vulnerability. If an attacker provides a malicious string, it can make markdown2 processing difficult or delayed for an extended period of time.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jr9p-r423-9m2r

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-jr9p-r423-9m2r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-26813

Advisory: markdown2 Regular Expression Denial of Service
IDs: CVE-2021-26813, GHSA-jr9p-r423-9m2r
Record: https://patchnext.com/advisories/cve-2021-26813 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: markdown2 2.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI markdown2: affected >= 1.0.1.18, < 2.4.0; fixed in 2.4.0

## Suggested inspection (read-only)
- `python -m pip show markdown2`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on markdown2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jr9p-r423-9m2r (OSV record GHSA-jr9p-r423-9m2r lists affected ranges: PyPI markdown2 >=1.0.1.18 <2.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jr9p-r423-9m2r (GitHub-reviewed advisory GHSA-jr9p-r423-9m2r lists affected ranges: PyPI markdown2 >=1.0.1.18 <2.4.0)

Commands are suggestions: review each one before running it.

Loading voting…