Skip to content

← Actionable
Medium, CVSS 5.5

Error on unsupported architectures in raw-cpuid

CVE-2021-26307GHSA-jrf8-cmgg-gv2m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (raw-cpuid 9.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io raw-cpuid

    Affected
    < 9.0.0
    Fixed in
    9.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-26307: 0.35% estimated exploitation activity in the next 30 days; percentile 28.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

nativecpuid::cpuidcount() exposes the unsafe cpuidcount() intrinsic from core::arch::x86 or core::arch::x8664 as a safe function, and uses it internally, without checking the safety requirement: The CPU the program is currently running on supports the function being called. CPUID is available in most, but not all, x86/x8664 environments. The crate compiles only on these architectures, so others are unaffected. This issue is mitigated by the fact that affected programs are expected to crash deterministically every time. The flaw has been fixed in v9.0.0, by intentionally breaking compilation when targeting SGX or 32-bit x86 without SSE. This covers all affected CPUs.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jrf8-cmgg-gv2m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-26307

Advisory: Error on unsupported architectures in raw-cpuid
IDs: CVE-2021-26307, GHSA-jrf8-cmgg-gv2m
Record: https://patchnext.com/advisories/cve-2021-26307 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: raw-cpuid 9.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io raw-cpuid: affected < 9.0.0; fixed in 9.0.0

## Suggested inspection (read-only)
- crates.io raw-cpuid: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on raw-cpuid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jrf8-cmgg-gv2m (GitHub-reviewed advisory GHSA-jrf8-cmgg-gv2m lists affected ranges: crates.io raw-cpuid >=0 <9.0.0)

Commands are suggestions: review each one before running it.

Loading voting…