Inclusion of Functionality from Untrusted Control Sphere in CKEditor 4
CVE-2021-26272GHSA-wpvm-wqr4-p7cw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckeditor4 4.16.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ckeditor4
- Affected
- < 4.16.0
- Fixed in
- 4.16.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wpvm-wqr4-p7cw lists affected ranges: npm ckeditor4 >=0 <4.16.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wpvm-wqr4-p7cw lists affected ranges: npm ckeditor4 >=0 <4.16.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-26272: 2.35% estimated exploitation activity in the next 30 days; percentile 83.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
It was possible to execute a ReDoS-type attack inside CKEditor 4 before 4.16 by persuading a victim to paste crafted URL-like text into the editor, and then press Enter or Space (in the Autolink plugin).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wpvm-wqr4-p7cw
- Revision 1 · created ·
Published from osv record GHSA-wpvm-wqr4-p7cw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-26272 Advisory: Inclusion of Functionality from Untrusted Control Sphere in CKEditor 4 IDs: CVE-2021-26272, GHSA-wpvm-wqr4-p7cw Record: https://patchnext.com/advisories/cve-2021-26272 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ckeditor4 4.16.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ckeditor4: affected < 4.16.0; fixed in 4.16.0 ## Suggested inspection (read-only) - `npm ls ckeditor4 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ckeditor4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wpvm-wqr4-p7cw (OSV record GHSA-wpvm-wqr4-p7cw lists affected ranges: npm ckeditor4 >=0 <4.16.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wpvm-wqr4-p7cw (GitHub-reviewed advisory GHSA-wpvm-wqr4-p7cw lists affected ranges: npm ckeditor4 >=0 <4.16.0) Commands are suggestions: review each one before running it.
Loading voting…