Improper Authentication in Atlassian Connect Spring Boot
CVE-2021-26077GHSA-2x7v-w2mv-f3rx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.atlassian.connect:atlassian-connect-spring-boot 2.1.5, 2.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.atlassian.connect:atlassian-connect-spring-boot
- Affected
- >= 1.1.0, < 2.1.3>= 2.1.4, < 2.1.5
- Fixed in
- 2.1.5, 2.1.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2x7v-w2mv-f3rx lists affected ranges: Maven com.atlassian.connect:atlassian-connect-spring-boot >=1.1.0 =2.1.4 <2.1.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-26077: 0.95% estimated exploitation activity in the next 30 days; percentile 61.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Broken Authentication in Atlassian Connect Spring Boot (ACSB) in version 1.1.0 before 2.1.3 and from version 2.1.4 before 2.1.5: Atlassian Connect Spring Boot is a Java Spring Boot package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Spring Boot app occurs with a server-to-server JWT or a context JWT. Atlassian Connect Spring Boot versions 1.1.0 before 2.1.3 and versions 2.1.4 before 2.1.5 erroneously accept context JWTs in lifecycle endpoints (such as installation) where only server-to-server JWTs should be accepted, permitting an attacker to send authenticated re-installation events to an app.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2x7v-w2mv-f3rx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-26077 Advisory: Improper Authentication in Atlassian Connect Spring Boot IDs: CVE-2021-26077, GHSA-2x7v-w2mv-f3rx Record: https://patchnext.com/advisories/cve-2021-26077 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.atlassian.connect:atlassian-connect-spring-boot 2.1.5, 2.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.atlassian.connect:atlassian-connect-spring-boot: affected >= 1.1.0, < 2.1.3; >= 2.1.4, < 2.1.5; fixed in 2.1.5, 2.1.3 ## Suggested inspection (read-only) - Maven com.atlassian.connect:atlassian-connect-spring-boot: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.atlassian.connect:atlassian-connect-spring-boot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2x7v-w2mv-f3rx (GitHub-reviewed advisory GHSA-2x7v-w2mv-f3rx lists affected ranges: Maven com.atlassian.connect:atlassian-connect-spring-boot >=1.1.0 =2.1.4 <2.1.5) Commands are suggestions: review each one before running it.
Loading voting…