Broken Authentication in Atlassian Connect Express
CVE-2021-26073GHSA-4v96-m8xv-x83v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (atlassian-connect-express 6.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 3.0.2, < 6.6.0
- Fixed in
- 6.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4v96-m8xv-x83v lists affected ranges: npm atlassian-connect-express >=3.0.2 <6.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4v96-m8xv-x83v lists affected ranges: npm atlassian-connect-express >=3.0.2 <6.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
- EPSS
- CVE-2021-26073: 0.92% estimated exploitation activity in the next 30 days; percentile 60.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Broken Authentication in Atlassian Connect Express (ACE) from version 3.0.2 before version 6.6.0: Atlassian Connect Express is a Node.js package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Express app occurs with a server-to-server JWT or a context JWT. Atlassian Connect Express versions between 3.0.2 - 6.5.0 erroneously accept context JWTs in lifecycle endpoints (such as installation) where only server-to-server JWTs should be accepted, permitting an attacker to send authenticated re-installation events to an app.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4v96-m8xv-x83v
- Revision 1 · created ·
Published from osv record GHSA-4v96-m8xv-x83v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-26073 Advisory: Broken Authentication in Atlassian Connect Express IDs: CVE-2021-26073, GHSA-4v96-m8xv-x83v Record: https://patchnext.com/advisories/cve-2021-26073 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: atlassian-connect-express 6.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm atlassian-connect-express: affected >= 3.0.2, < 6.6.0; fixed in 6.6.0 ## Suggested inspection (read-only) - `npm ls atlassian-connect-express --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on atlassian-connect-express. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4v96-m8xv-x83v (OSV record GHSA-4v96-m8xv-x83v lists affected ranges: npm atlassian-connect-express >=3.0.2 <6.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4v96-m8xv-x83v (GitHub-reviewed advisory GHSA-4v96-m8xv-x83v lists affected ranges: npm atlassian-connect-express >=3.0.2 <6.6.0) Commands are suggestions: review each one before running it.
Loading voting…