Cross-site Scripting in django-wiki
CVE-2021-25986GHSA-3m3h-v9hv-9j4h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wiki 0.7.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wiki
- Affected
- >= 0.0.20, < 0.7.9
- Fixed in
- 0.7.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3m3h-v9hv-9j4h lists affected ranges: PyPI wiki >=0.0.20 <0.7.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3m3h-v9hv-9j4h lists affected ranges: PyPI wiki >=0.0.20 <0.7.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2021-25986: 0.60% estimated exploitation activity in the next 30 days; percentile 48.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Django-wiki, versions 0.0.20 to 0.7.8 are vulnerable to Stored Cross-Site Scripting (XSS) in Notifications Section. An attacker who has access to edit pages can inject JavaScript payload in the title field. When a victim gets a notification regarding the changes made in the application, the payload in the notification panel renders and loads external JavaScript.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3m3h-v9hv-9j4h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3m3h-v9hv-9j4h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-25986 Advisory: Cross-site Scripting in django-wiki IDs: CVE-2021-25986, GHSA-3m3h-v9hv-9j4h Record: https://patchnext.com/advisories/cve-2021-25986 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wiki 0.7.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wiki: affected >= 0.0.20, < 0.7.9; fixed in 0.7.9 ## Suggested inspection (read-only) - `python -m pip show wiki`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wiki. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3m3h-v9hv-9j4h (OSV record GHSA-3m3h-v9hv-9j4h lists affected ranges: PyPI wiki >=0.0.20 <0.7.9 (fixed)) - Verified: https://github.com/advisories/GHSA-3m3h-v9hv-9j4h (GitHub-reviewed advisory GHSA-3m3h-v9hv-9j4h lists affected ranges: PyPI wiki >=0.0.20 <0.7.9) Commands are suggestions: review each one before running it.
Loading voting…