Skip to content

← Actionable
Medium, CVSS 4.9

Camaleon CMS vulnerable to Server-Side Request Forgery

CVE-2021-25972GHSA-vx6p-q4gj-x6xx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (camaleon_cms 2.6.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems camaleon_cms

    Affected
    >= 2.1.2.0, < 2.6.0.1
    Fixed in
    2.6.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2021-25972: 0.99% estimated exploitation activity in the next 30 days; percentile 62.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Camaleon CMS, versions 2.1.2.0 through 2.6.0, are vulnerable to Server-Side Request Forgery (SSRF) in the media upload feature, which allows admin users to fetch media files from external URLs but fails to validate URLs referencing to localhost or other internal servers. This allows attackers to read files stored in the internal server.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vx6p-q4gj-x6xx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-25972

Advisory: Camaleon CMS vulnerable to Server-Side Request Forgery
IDs: CVE-2021-25972, GHSA-vx6p-q4gj-x6xx
Record: https://patchnext.com/advisories/cve-2021-25972 (revision 1, source checked 26 Oct 2026, 15:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: camaleon_cms 2.6.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems camaleon_cms: affected >= 2.1.2.0, < 2.6.0.1; fixed in 2.6.0.1

## Suggested inspection (read-only)
- RubyGems camaleon_cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on camaleon_cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vx6p-q4gj-x6xx (GitHub-reviewed advisory GHSA-vx6p-q4gj-x6xx lists affected ranges: RubyGems camaleon_cms >=2.1.2.0 <2.6.0.1)

Commands are suggestions: review each one before running it.

Loading voting…