Camaleon CMS vulnerable to Uncaught Exception
CVE-2021-25971GHSA-r2w2-h6r8-3r53
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (camaleon_cms 2.6.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems camaleon_cms
- Affected
- >= 2.0.1, < 2.6.0.1
- Fixed in
- 2.6.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r2w2-h6r8-3r53 lists affected ranges: RubyGems camaleon_cms >=2.0.1 <2.6.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2021-25971: 1.01% estimated exploitation activity in the next 30 days; percentile 63.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Camaleon CMS, versions 2.0.1 through 2.6.0 are vulnerable to an Uncaught Exception. The app's media upload feature crashes permanently when an attacker with a low privileged access uploads a specially crafted .svg file.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r2w2-h6r8-3r53
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-25971 Advisory: Camaleon CMS vulnerable to Uncaught Exception IDs: CVE-2021-25971, GHSA-r2w2-h6r8-3r53 Record: https://patchnext.com/advisories/cve-2021-25971 (revision 1, source checked 26 Oct 2026, 15:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: camaleon_cms 2.6.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems camaleon_cms: affected >= 2.0.1, < 2.6.0.1; fixed in 2.6.0.1 ## Suggested inspection (read-only) - RubyGems camaleon_cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on camaleon_cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r2w2-h6r8-3r53 (GitHub-reviewed advisory GHSA-r2w2-h6r8-3r53 lists affected ranges: RubyGems camaleon_cms >=2.0.1 <2.6.0.1) Commands are suggestions: review each one before running it.
Loading voting…