Camaleon CMS Stored Cross-site Scripting vulnerability
CVE-2021-25969GHSA-x78v-4fvj-rg9j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (camaleon_cms 2.6.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems camaleon_cms
- Affected
- >= 0.0.1, < 2.6.0.1
- Fixed in
- 2.6.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x78v-4fvj-rg9j lists affected ranges: RubyGems camaleon_cms >=0.0.1 <2.6.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-25969: 0.81% estimated exploitation activity in the next 30 days; percentile 56.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In “Camaleon CMS” application, versions 0.0.1 through 2.6.0 are vulnerable to stored XSS, that allows unprivileged application users to store malicious scripts in the comments section of the post. These scripts are executed in a victim’s browser when they open the page containing the malicious comment.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x78v-4fvj-rg9j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-25969 Advisory: Camaleon CMS Stored Cross-site Scripting vulnerability IDs: CVE-2021-25969, GHSA-x78v-4fvj-rg9j Record: https://patchnext.com/advisories/cve-2021-25969 (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: camaleon_cms 2.6.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems camaleon_cms: affected >= 0.0.1, < 2.6.0.1; fixed in 2.6.0.1 ## Suggested inspection (read-only) - RubyGems camaleon_cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on camaleon_cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x78v-4fvj-rg9j (GitHub-reviewed advisory GHSA-x78v-4fvj-rg9j lists affected ranges: RubyGems camaleon_cms >=0.0.1 <2.6.0.1) Commands are suggestions: review each one before running it.
Loading voting…