Cross-site scripting in sickrage
CVE-2021-25926GHSA-x823-j7c4-vpc5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sickrage 10.0.11.dev2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sickrage
- Affected
- >= 9.3.54, <= 10.0.11.dev1
- Fixed in
- 10.0.11.dev2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x823-j7c4-vpc5 lists affected ranges: PyPI sickrage >=9.3.54 <10.0.11.dev2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x823-j7c4-vpc5 lists affected ranges: PyPI sickrage >=9.3.54 <=10.0.11.dev1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-25926: 0.82% estimated exploitation activity in the next 30 days; percentile 57.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the quicksearch feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x823-j7c4-vpc5
- Revision 1 · created ·
Published from osv record GHSA-x823-j7c4-vpc5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-25926 Advisory: Cross-site scripting in sickrage IDs: CVE-2021-25926, GHSA-x823-j7c4-vpc5 Record: https://patchnext.com/advisories/cve-2021-25926 (revision 2, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sickrage 10.0.11.dev2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sickrage: affected >= 9.3.54, <= 10.0.11.dev1; fixed in 10.0.11.dev2 ## Suggested inspection (read-only) - `python -m pip show sickrage`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sickrage. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x823-j7c4-vpc5 (OSV record GHSA-x823-j7c4-vpc5 lists affected ranges: PyPI sickrage >=9.3.54 <10.0.11.dev2 (fixed)) - Verified: https://github.com/advisories/GHSA-x823-j7c4-vpc5 (GitHub-reviewed advisory GHSA-x823-j7c4-vpc5 lists affected ranges: PyPI sickrage >=9.3.54 <=10.0.11.dev1) Commands are suggestions: review each one before running it.
Loading voting…