Skip to content

← Actionable
Medium, CVSS 5.4amended

Cross-site scripting in SiCKRAGE

CVE-2021-25925GHSA-rmp7-f2vp-3rq4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sickrage 10.0.11.dev2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI sickrage

    Affected
    >= 4.2.0, <= 10.0.11.dev1
    Fixed in
    10.0.11.dev2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-25925: 0.66% estimated exploitation activity in the next 30 days; percentile 51.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rmp7-f2vp-3rq4

  2. Revision 1 · created ·

    Published from osv record GHSA-rmp7-f2vp-3rq4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-25925

Advisory: Cross-site scripting in SiCKRAGE
IDs: CVE-2021-25925, GHSA-rmp7-f2vp-3rq4
Record: https://patchnext.com/advisories/cve-2021-25925 (revision 2, source checked 26 Oct 2026, 13:23 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sickrage 10.0.11.dev2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI sickrage: affected >= 4.2.0, <= 10.0.11.dev1; fixed in 10.0.11.dev2

## Suggested inspection (read-only)
- `python -m pip show sickrage`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sickrage.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rmp7-f2vp-3rq4 (OSV record GHSA-rmp7-f2vp-3rq4 lists affected ranges: PyPI sickrage >=4.2.0 <10.0.11.dev2 (fixed))
- Verified: https://github.com/advisories/GHSA-rmp7-f2vp-3rq4 (GitHub-reviewed advisory GHSA-rmp7-f2vp-3rq4 lists affected ranges: PyPI sickrage >=4.2.0 <=10.0.11.dev1)

Commands are suggestions: review each one before running it.

Loading voting…