Skip to content

← Actionable
Critical, CVSS 9.8amended

Prototype Pollution in set-or-get

CVE-2021-25913GHSA-6rv4-4qv6-88g2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (set-or-get 1.2.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm set-or-get

    Affected
    >= 1.0.0, < 1.2.11
    Fixed in
    1.2.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-25913: 4.38% estimated exploitation activity in the next 30 days; percentile 91.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Prototype pollution vulnerability in ‘set-or-get’ version 1.0.0 through 1.2.10 allows an attacker to cause a denial of service and may lead to remote code execution.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6rv4-4qv6-88g2

  2. Revision 1 · created ·

    Published from osv record GHSA-6rv4-4qv6-88g2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-25913

Advisory: Prototype Pollution in set-or-get
IDs: CVE-2021-25913, GHSA-6rv4-4qv6-88g2
Record: https://patchnext.com/advisories/cve-2021-25913 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: set-or-get 1.2.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm set-or-get: affected >= 1.0.0, < 1.2.11; fixed in 1.2.11

## Suggested inspection (read-only)
- `npm ls set-or-get --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on set-or-get.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6rv4-4qv6-88g2 (OSV record GHSA-6rv4-4qv6-88g2 lists affected ranges: npm set-or-get >=1.0.0 <1.2.11 (fixed))
- Verified: https://github.com/advisories/GHSA-6rv4-4qv6-88g2 (GitHub-reviewed advisory GHSA-6rv4-4qv6-88g2 lists affected ranges: npm set-or-get >=1.0.0 <1.2.11)

Commands are suggestions: review each one before running it.

Loading voting…