Double free in glsl-layout
CVE-2021-25902GHSA-cx4j-fxr7-jxg8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (glsl-layout 0.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io glsl-layout
- Affected
- < 0.4.0
- Fixed in
- 0.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cx4j-fxr7-jxg8 lists affected ranges: crates.io glsl-layout >=0 <0.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-25902: 1.41% estimated exploitation activity in the next 30 days; percentile 72.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of this crate did not guard against panic within the user-provided function f (2nd parameter of fn maparray), and thus panic within f causes double drop of a single object. The flaw was corrected in the 0.4.0 release by wrapping the object vulnerable to a double drop within ManuallyDrop<T.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cx4j-fxr7-jxg8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-25902 Advisory: Double free in glsl-layout IDs: CVE-2021-25902, GHSA-cx4j-fxr7-jxg8 Record: https://patchnext.com/advisories/cve-2021-25902 (revision 1, source checked 26 Oct 2026, 15:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: glsl-layout 0.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io glsl-layout: affected < 0.4.0; fixed in 0.4.0 ## Suggested inspection (read-only) - crates.io glsl-layout: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on glsl-layout. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cx4j-fxr7-jxg8 (GitHub-reviewed advisory GHSA-cx4j-fxr7-jxg8 lists affected ranges: crates.io glsl-layout >=0 <0.4.0) Commands are suggestions: review each one before running it.
Loading voting…