Skip to content

← Actionable
Critical, CVSS 9.8

Buffer overflow in SmallVec::insert_many

CVE-2021-25900GHSA-43w2-9j62-hq99

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (smallvec 1.6.1, 0.6.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io smallvec

    Affected
    >= 0.6.3, < 0.6.14>= 1.0.0, < 1.6.1
    Fixed in
    1.6.1, 0.6.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-25900: 1.72% estimated exploitation activity in the next 30 days; percentile 77.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A bug in the SmallVec::insertmany method caused it to allocate a buffer that was smaller than needed. It then wrote past the end of the buffer, causing a buffer overflow and memory corruption on the heap. This bug was only triggered if the iterator passed to insertmany yielded more items than the lower bound returned from its sizehint method. The flaw was corrected in smallvec 0.6.14 and 1.6.1, by ensuring that additional space is always reserved for each item inserted. The fix also simplified the implementation of insertmany to use less unsafe code, so it is easier to verify its correctness.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-43w2-9j62-hq99

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-25900

Advisory: Buffer overflow in SmallVec::insert_many
IDs: CVE-2021-25900, GHSA-43w2-9j62-hq99
Record: https://patchnext.com/advisories/cve-2021-25900 (revision 1, source checked 26 Oct 2026, 15:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: smallvec 1.6.1, 0.6.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io smallvec: affected >= 0.6.3, < 0.6.14; >= 1.0.0, < 1.6.1; fixed in 1.6.1, 0.6.14

## Suggested inspection (read-only)
- crates.io smallvec: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on smallvec.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-43w2-9j62-hq99 (GitHub-reviewed advisory GHSA-43w2-9j62-hq99 lists affected ranges: crates.io smallvec >=0.6.3 =1.0.0 <1.6.1)

Commands are suggestions: review each one before running it.

Loading voting…