Skip to content

← Actionable
High, CVSS 8.1

Files or Directories Accessible to External Parties in kubernetes

CVE-2021-25741GHSA-f5f7-6478-qm6p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.22.2, 1.21.5, 1.20.11, 1.19.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go k8s.io/kubernetes

    Affected
    < 1.19.15>= 1.20.0, < 1.20.11>= 1.21.0, < 1.21.5>= 1.22.0, < 1.22.2
    Fixed in
    1.21.5, 1.19.15, 1.22.2, 1.20.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2021-25741: 7.96% estimated exploitation activity in the next 30 days; percentile 94.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A security issue was discovered in Kubernetes where a user may be able to create a container with subpath volume mounts to access files & directories outside of the volume, including on the host filesystem.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f5f7-6478-qm6p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-25741

Advisory: Files or Directories Accessible to External Parties in kubernetes
IDs: CVE-2021-25741, GHSA-f5f7-6478-qm6p
Record: https://patchnext.com/advisories/cve-2021-25741 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.22.2, 1.21.5, 1.20.11, 1.19.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go k8s.io/kubernetes: affected < 1.19.15; >= 1.20.0, < 1.20.11; >= 1.21.0, < 1.21.5; >= 1.22.0, < 1.22.2; fixed in 1.21.5, 1.19.15, 1.22.2, 1.20.11

## Suggested inspection (read-only)
- Go k8s.io/kubernetes: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on k8s.io/kubernetes.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f5f7-6478-qm6p (GitHub-reviewed advisory GHSA-f5f7-6478-qm6p lists affected ranges: Go k8s.io/kubernetes >=0 =1.20.0 =1.21.0 =1.22.0 <1.22.2)

Commands are suggestions: review each one before running it.

Loading voting…