Skip to content

← Actionable
Medium, CVSS 4.8

Incomplete List of Disallowed Inputs in Kubernetes

CVE-2021-25737GHSA-mfv7-gq43-w965

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.21.1, 1.20.7, 1.19.11, 1.18.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go k8s.io/kubernetes

    Affected
    >= 1.16.0, < 1.18.19>= 1.19.0, < 1.19.11>= 1.20.0, < 1.20.7>= 1.21.0, <= 1.21.0
    Fixed in
    1.19.11, 1.18.19, 1.21.1, 1.20.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-25737: 1.33% estimated exploitation activity in the next 30 days; percentile 71.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A security issue was discovered in Kubernetes where a user may be able to redirect pod traffic to private networks on a Node. Kubernetes already prevents creation of Endpoint IPs in the localhost or link-local range, but the same validation was not performed on EndpointSlice IPs.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mfv7-gq43-w965

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-25737

Advisory: Incomplete List of Disallowed Inputs in Kubernetes
IDs: CVE-2021-25737, GHSA-mfv7-gq43-w965
Record: https://patchnext.com/advisories/cve-2021-25737 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.21.1, 1.20.7, 1.19.11, 1.18.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go k8s.io/kubernetes: affected >= 1.16.0, < 1.18.19; >= 1.19.0, < 1.19.11; >= 1.20.0, < 1.20.7; >= 1.21.0, <= 1.21.0; fixed in 1.19.11, 1.18.19, 1.21.1, 1.20.7

## Suggested inspection (read-only)
- Go k8s.io/kubernetes: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on k8s.io/kubernetes.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mfv7-gq43-w965 (GitHub-reviewed advisory GHSA-mfv7-gq43-w965 lists affected ranges: Go k8s.io/kubernetes >=1.16.0 =1.19.0 =1.20.0 =1.21.0 <=1.21.0)

Commands are suggestions: review each one before running it.

Loading voting…