SaltStack Salt Improper Authentication vulnerability
CVE-2021-25281GHSA-xxw3-765m-f37p
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI salt
- Affected
- < 2015.8.13>= 2016.3.0, < 2016.11.5>= 2016.11.7, < 2016.11.10>= 2017.5.0, < 2017.7.8>= 2018.2.0, <= 2018.3.5>= 2019.2.0, < 2019.2.8>= 3000, < 3000.7>= 3001, < 3001.5>= 3002, < 3002.3
- Fixed in
- 2016.11.5, 3000.7, 2019.2.8, 2015.8.13, 3002.3, 3001.5, 2017.7.8, 2016.11.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xxw3-765m-f37p lists affected ranges: PyPI salt >=0 =2016.3.0 =2016.11.7 =2017.5.0 =2018.2.0 =2019.2.0 =3000 =3001 =3002 <3002.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xxw3-765m-f37p lists affected ranges: PyPI salt >=0 =2016.3.0 =2016.11.7 =2017.5.0 =2018.2.0 =2019.2.0 =3000 =3001 =3002 <3002.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-25281: 73.13% estimated exploitation activity in the next 30 days; percentile 99.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in through SaltStack Salt before 3002.5. salt-api does not honor eauth credentials for the wheelasync client. Thus, an attacker can remotely run any wheel modules on the master.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xxw3-765m-f37p
- Revision 1 · created ·
Published from osv record GHSA-xxw3-765m-f37p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-25281 Advisory: SaltStack Salt Improper Authentication vulnerability IDs: CVE-2021-25281, GHSA-xxw3-765m-f37p Record: https://patchnext.com/advisories/cve-2021-25281 (revision 2, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: salt 3002.3, 3001.5, 3000.7, 2019.2.8, 2017.7.8, 2016.11.10, 2016.11.5, 2015.8.13. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI salt: affected < 2015.8.13; >= 2016.3.0, < 2016.11.5; >= 2016.11.7, < 2016.11.10; >= 2017.5.0, < 2017.7.8; >= 2018.2.0, <= 2018.3.5; >= 2019.2.0, < 2019.2.8; >= 3000, < 3000.7; >= 3001, < 3001.5; >= 3002, < 3002.3; fixed in 2016.11.5, 3000.7, 2019.2.8, 2015.8.13, 3002.3, 3001.5, 2017.7.8, 2016.11.10 ## Suggested inspection (read-only) - `python -m pip show salt`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on salt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xxw3-765m-f37p (OSV record GHSA-xxw3-765m-f37p lists affected ranges: PyPI salt >=0 =2016.3.0 =2016.11.7 =2017.5.0 =2018.2.0 =2019.2.0 =3000 =3001 =3002 <3002.3 (fixed)) - Verified: https://github.com/advisories/GHSA-xxw3-765m-f37p (GitHub-reviewed advisory GHSA-xxw3-765m-f37p lists affected ranges: PyPI salt >=0 =2016.3.0 =2016.11.7 =2017.5.0 =2018.2.0 =2019.2.0 =3000 =3001 =3002 <3002.3) Commands are suggestions: review each one before running it.
Loading voting…