Skip to content

← Actionable
High, CVSS 7.5

Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat

CVE-2021-25122GHSA-j39c-c8hj-x4j3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-coyote 10.0.2; org.apache.tomcat.embed:tomcat-embed-core 10.0.2, 9.0.43, 8.5.63), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-j39c-c8hj-x4j3 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=8.5.0 =10.0.0-M1 =9.0.0-M1 =10.0.0-M1 <10.0.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2021-25122: 18.11% estimated exploitation activity in the next 30 days; percentile 97.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When responding to new h2c connection requests, Apache Tomcat versions 10.0.0-M1 to 10.0.0, 9.0.0.M1 to 9.0.41 and 8.5.0 to 8.5.61 could duplicate request headers and a limited amount of request body from one request to another meaning user A and user B could both see the results of user A's request.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j39c-c8hj-x4j3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-25122

Advisory: Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat
IDs: CVE-2021-25122, GHSA-j39c-c8hj-x4j3
Record: https://patchnext.com/advisories/cve-2021-25122 (revision 1, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-coyote 10.0.2; org.apache.tomcat.embed:tomcat-embed-core 10.0.2, 9.0.43, 8.5.63. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-coyote: affected >= 10.0.0-M1, < 10.0.2; fixed in 10.0.2
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 8.5.0, < 8.5.63; >= 10.0.0-M1, < 10.0.2; >= 9.0.0-M1, < 9.0.43; fixed in 8.5.63, 9.0.43, 10.0.2

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j39c-c8hj-x4j3 (GitHub-reviewed advisory GHSA-j39c-c8hj-x4j3 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=8.5.0 =10.0.0-M1 =9.0.0-M1 =10.0.0-M1 <10.0.2)

Commands are suggestions: review each one before running it.

Loading voting…