JetPack Exposure of Resource to Wrong Sphere
CVE-2021-24374GHSA-5hr6-r8h6-wh22
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (automattic/jetpack 9.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist automattic/jetpack
- Affected
- < 9.8
- Fixed in
- 9.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5hr6-r8h6-wh22 lists affected ranges: Packagist automattic/jetpack >=0 <9.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2021-24374: 1.49% estimated exploitation activity in the next 30 days; percentile 74.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Jetpack Carousel module of the JetPack WordPress plugin before 9.8 allows users to create a "carousel" type image gallery and allows users to comment on the images. A security vulnerability was found within the Jetpack Carousel module by nguyenhgvcs that allowed the comments of non-published page/posts to be leaked.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5hr6-r8h6-wh22
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-24374 Advisory: JetPack Exposure of Resource to Wrong Sphere IDs: CVE-2021-24374, GHSA-5hr6-r8h6-wh22 Record: https://patchnext.com/advisories/cve-2021-24374 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: automattic/jetpack 9.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist automattic/jetpack: affected < 9.8; fixed in 9.8 ## Suggested inspection (read-only) - Packagist automattic/jetpack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on automattic/jetpack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5hr6-r8h6-wh22 (GitHub-reviewed advisory GHSA-5hr6-r8h6-wh22 lists affected ranges: Packagist automattic/jetpack >=0 <9.8) Commands are suggestions: review each one before running it.
Loading voting…