Skip to content

← Actionable
Medium, CVSS 5.9

Information Disclosure in Apache Tomcat

CVE-2021-24122GHSA-2rvv-w9r2-rg7m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat.embed:tomcat-embed-core 10.0.0-M10, 9.0.40, 8.5.60, 7.0.107), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-2rvv-w9r2-rg7m lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=10.0.0-M1 =9.0.0 =8.5.0 =7.0.0 <7.0.107

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2021-24122: 22.85% estimated exploitation activity in the next 30 days; percentile 97.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When serving resources from a network location using the NTFS file system, Apache Tomcat versions 10.0.0-M1 to 10.0.0-M9, 9.0.0.M1 to 9.0.39, 8.5.0 to 8.5.59 and 7.0.0 to 7.0.106 were susceptible to JSP source code disclosure in some configurations. The root cause was the unexpected behaviour of the JRE API File.getCanonicalPath() which in turn was caused by the inconsistent behaviour of the Windows API (FindFirstFileW) in some circumstances.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2rvv-w9r2-rg7m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-24122

Advisory: Information Disclosure in Apache Tomcat
IDs: CVE-2021-24122, GHSA-2rvv-w9r2-rg7m
Record: https://patchnext.com/advisories/cve-2021-24122 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat.embed:tomcat-embed-core 10.0.0-M10, 9.0.40, 8.5.60, 7.0.107. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 10.0.0-M1, <= 10.0.0-M9; >= 9.0.0, < 9.0.40; >= 8.5.0, < 8.5.60; >= 7.0.0, < 7.0.107; fixed in 9.0.40, 8.5.60, 10.0.0-M10, 7.0.107

## Suggested inspection (read-only)
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat.embed:tomcat-embed-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2rvv-w9r2-rg7m (GitHub-reviewed advisory GHSA-2rvv-w9r2-rg7m lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=10.0.0-M1 =9.0.0 =8.5.0 =7.0.0 <7.0.107)

Commands are suggestions: review each one before running it.

Loading voting…