Access of Resource Using Incompatible Type in Hermes
CVE-2021-24044GHSA-7mhc-prgv-r3q4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (hermes-engine 0.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm hermes-engine
- Affected
- <= 0.9.0
- Fixed in
- 0.10.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7mhc-prgv-r3q4 lists affected ranges: npm hermes-engine >=0 <0.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7mhc-prgv-r3q4 lists affected ranges: npm hermes-engine >=0 <=0.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-24044: 1.26% estimated exploitation activity in the next 30 days; percentile 69.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
By passing invalid javascript code where await and yield were called upon non-async and non-generator getter/setter functions, Hermes would invoke generator functions and error out on invalid await/yield positions. This could result in segmentation fault as a consequence of type confusion error, with a low chance of RCE. This issue affects Hermes versions prior to v0.10.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7mhc-prgv-r3q4
- Revision 1 · created ·
Published from osv record GHSA-7mhc-prgv-r3q4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-24044 Advisory: Access of Resource Using Incompatible Type in Hermes IDs: CVE-2021-24044, GHSA-7mhc-prgv-r3q4 Record: https://patchnext.com/advisories/cve-2021-24044 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: hermes-engine 0.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm hermes-engine: affected <= 0.9.0; fixed in 0.10.0 ## Suggested inspection (read-only) - `npm ls hermes-engine --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on hermes-engine. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7mhc-prgv-r3q4 (OSV record GHSA-7mhc-prgv-r3q4 lists affected ranges: npm hermes-engine >=0 <0.10.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7mhc-prgv-r3q4 (GitHub-reviewed advisory GHSA-7mhc-prgv-r3q4 lists affected ranges: npm hermes-engine >=0 <=0.9.0) Commands are suggestions: review each one before running it.
Loading voting…