Cross-site scripting in Bleach
CVE-2021-23980GHSA-vv2x-vrpj-qqpq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bleach 3.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI bleach
- Affected
- < 3.3.0
- Fixed in
- 3.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vv2x-vrpj-qqpq lists affected ranges: PyPI bleach >=0 <3.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vv2x-vrpj-qqpq lists affected ranges: PyPI bleach >=0 <3.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2021-23980: 0.48% estimated exploitation activity in the next 30 days; percentile 41.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A mutation XSS affects users calling bleach.clean with all of: svg or math in the allowed tags p or br in allowed tags style, title, noscript, script, textarea, noframes, iframe, or xmp in allowed tags the keyword argument stripcomments=False Note: none of the above tags are in the default allowed tags and stripcomments defaults to True. Patches Users are encouraged to upgrade to bleach v3.3.0 or greater. Note: bleach v3.3.0 introduces a breaking change to escape HTML comments by default. Workarounds modify bleach.clean calls to at least one of: not allow the style, title, noscript, script, textarea, noframes, iframe, or xmp tag not allow svg or math tags not allow p or br tags set stripcomments=True A strong Content-Security-Policy without unsafe-inline and unsafe-eval script-srcs) will also help mitigate the risk. References https://bugzilla.mozilla.org/showbug.cgi?id=1689399 https://advisory.checkmarx.net/advisory/CX-2021-4303…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vv2x-vrpj-qqpq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vv2x-vrpj-qqpq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23980 Advisory: Cross-site scripting in Bleach IDs: CVE-2021-23980, GHSA-vv2x-vrpj-qqpq Record: https://patchnext.com/advisories/cve-2021-23980 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bleach 3.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI bleach: affected < 3.3.0; fixed in 3.3.0 ## Suggested inspection (read-only) - `python -m pip show bleach`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bleach. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vv2x-vrpj-qqpq (OSV record GHSA-vv2x-vrpj-qqpq lists affected ranges: PyPI bleach >=0 <3.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vv2x-vrpj-qqpq (GitHub-reviewed advisory GHSA-vv2x-vrpj-qqpq lists affected ranges: PyPI bleach >=0 <3.3.0) Commands are suggestions: review each one before running it.
Loading voting…