Integer Overflow in openssl-src
CVE-2021-23840GHSA-qgm6-9472-pwq7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 15.10.0, 14.16.0, 12.21.0, 10.24.0; openssl-src 111.14.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 10.0.0, < 10.24.0>= 12.0.0, < 12.21.0>= 14.0.0, < 14.16.0>= 15.0.0, < 15.10.0
- Fixed in
- 15.10.0, 10.24.0, 14.16.0, 12.21.0
crates.io openssl-src
- Affected
- < 111.14.0
- Fixed in
- 111.14.0
Sources
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2021-23840 to 2021-02-23.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 75 lists CVE-2021-23840 affecting node >=10.0.0 =12.0.0 =14.0.0 =15.0.0 <15.10.0
VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qgm6-9472-pwq7 lists affected ranges: crates.io openssl-src >=0 <111.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-23840: 50.73% estimated exploitation activity in the next 30 days; percentile 98.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Calls to EVPCipherUpdate, EVPEncryptUpdate and EVPDecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from vendor_advisory record nodejs-security-wg:core:75
- Revision 2 · published ·
Published from ghsa record GHSA-qgm6-9472-pwq7
- Revision 1 · created ·
Created from vendor_advisory record nodejs-security-wg:core:75
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23840 Advisory: Integer Overflow in openssl-src IDs: CVE-2021-23840, GHSA-qgm6-9472-pwq7 Record: https://patchnext.com/advisories/cve-2021-23840 (revision 3, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node 15.10.0, 14.16.0, 12.21.0, 10.24.0; openssl-src 111.14.0. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 10.0.0, < 10.24.0; >= 12.0.0, < 12.21.0; >= 14.0.0, < 14.16.0; >= 15.0.0, < 15.10.0; fixed in 15.10.0, 10.24.0, 14.16.0, 12.21.0 - crates.io openssl-src: affected < 111.14.0; fixed in 111.14.0 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. - crates.io openssl-src: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node, openssl-src. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2021-23840 to 2021-02-23.) - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/75.json (Node.js security working group core entry 75 lists CVE-2021-23840 affecting node >=10.0.0 =12.0.0 =14.0.0 =15.0.0 <15.10.0) - Verified: https://github.com/advisories/GHSA-qgm6-9472-pwq7 (GitHub-reviewed advisory GHSA-qgm6-9472-pwq7 lists affected ranges: crates.io openssl-src >=0 <111.14.0) Commands are suggestions: review each one before running it.
Loading voting…