Incorrect Authorization in latte/latte
CVE-2021-23803GHSA-6pj2-5fqq-xvjc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (latte/latte 2.10.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist latte/latte
- Affected
- < 2.10.6
- Fixed in
- 2.10.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6pj2-5fqq-xvjc lists affected ranges: Packagist latte/latte >=0 <2.10.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-23803: 1.63% estimated exploitation activity in the next 30 days; percentile 76.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package latte/latte before 2.10.6. There is a way to bypass allowFunctions that will affect the security of the application. When the template is set to allow/disallow the use of certain functions, adding control characters (x00-x08) after the function will bypass these restrictions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6pj2-5fqq-xvjc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23803 Advisory: Incorrect Authorization in latte/latte IDs: CVE-2021-23803, GHSA-6pj2-5fqq-xvjc Record: https://patchnext.com/advisories/cve-2021-23803 (revision 1, source checked 26 Oct 2026, 14:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: latte/latte 2.10.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist latte/latte: affected < 2.10.6; fixed in 2.10.6 ## Suggested inspection (read-only) - Packagist latte/latte: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on latte/latte. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6pj2-5fqq-xvjc (GitHub-reviewed advisory GHSA-6pj2-5fqq-xvjc lists affected ranges: Packagist latte/latte >=0 <2.10.6) Commands are suggestions: review each one before running it.
Loading voting…