Prototype Pollution in litespeed.js and appwrite/server-ce
CVE-2021-23682GHSA-v9p9-535w-4285
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litespeed.js 0.3.12; appwrite/server-ce 0.12.2, 0.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm litespeed.js
- Affected
- < 0.3.12
- Fixed in
- 0.3.12
Packagist appwrite/server-ce
- Affected
- >= 0.12.0, < 0.12.2< 0.11.1
- Fixed in
- 0.11.1, 0.12.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v9p9-535w-4285 lists affected ranges: npm litespeed.js >=0 =0.12.0 =0 <0.11.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v9p9-535w-4285 lists affected ranges: npm litespeed.js >=0 =0.12.0 =0 <0.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-23682: 2.12% estimated exploitation activity in the next 30 days; percentile 81.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package litespeed.js before 0.3.12; the package appwrite/server-ce from 0.12.0 and before 0.12.2, before 0.11.1. When parsing the query string in the getJsonFromUrl function, the key that is set in the result object is not properly sanitized leading to a Prototype Pollution vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v9p9-535w-4285
- Revision 1 · created ·
Published from osv record GHSA-v9p9-535w-4285
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23682 Advisory: Prototype Pollution in litespeed.js and appwrite/server-ce IDs: CVE-2021-23682, GHSA-v9p9-535w-4285 Record: https://patchnext.com/advisories/cve-2021-23682 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: litespeed.js 0.3.12; appwrite/server-ce 0.12.2, 0.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm litespeed.js: affected < 0.3.12; fixed in 0.3.12 - Packagist appwrite/server-ce: affected >= 0.12.0, < 0.12.2; < 0.11.1; fixed in 0.11.1, 0.12.2 ## Suggested inspection (read-only) - `npm ls litespeed.js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - Packagist appwrite/server-ce: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litespeed.js, appwrite/server-ce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v9p9-535w-4285 (OSV record GHSA-v9p9-535w-4285 lists affected ranges: npm litespeed.js >=0 =0.12.0 =0 <0.11.1 (fixed)) - Verified: https://github.com/advisories/GHSA-v9p9-535w-4285 (GitHub-reviewed advisory GHSA-v9p9-535w-4285 lists affected ranges: npm litespeed.js >=0 =0.12.0 =0 <0.11.1) Commands are suggestions: review each one before running it.
Loading voting…