Skip to content

← Actionable
Medium, CVSS 5.6amended

Prototype Pollution in dotty

CVE-2021-23624GHSA-6g47-63mv-qpgh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dotty 0.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm dotty

    Affected
    < 0.1.2
    Fixed in
    0.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.6 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2021-23624: 1.28% estimated exploitation activity in the next 30 days; percentile 70.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This affects the package dotty before 0.1.2. A type confusion vulnerability can lead to a bypass of CVE-2021-25912 when the user-provided keys used in the path parameter are arrays.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6g47-63mv-qpgh

  2. Revision 1 · created ·

    Published from osv record GHSA-6g47-63mv-qpgh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-23624

Advisory: Prototype Pollution in dotty
IDs: CVE-2021-23624, GHSA-6g47-63mv-qpgh
Record: https://patchnext.com/advisories/cve-2021-23624 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dotty 0.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm dotty: affected < 0.1.2; fixed in 0.1.2

## Suggested inspection (read-only)
- `npm ls dotty --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dotty.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6g47-63mv-qpgh (OSV record GHSA-6g47-63mv-qpgh lists affected ranges: npm dotty >=0 <0.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-6g47-63mv-qpgh (GitHub-reviewed advisory GHSA-6g47-63mv-qpgh lists affected ranges: npm dotty >=0 <0.1.2)

Commands are suggestions: review each one before running it.

Loading voting…