Skip to content

← Actionable
Critical, CVSS 9.8amended

Sandbox bypass in vm2

CVE-2021-23555GHSA-6pw2-5hjv-9pf7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.9.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    < 3.9.6
    Fixed in
    3.9.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-23555: 2.88% estimated exploitation activity in the next 30 days; percentile 86.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The package vm2 before 3.9.6 are vulnerable to Sandbox Bypass via direct access to host error objects generated by node internals during generation of a stacktraces, which can lead to execution of arbitrary code on the host machine.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6pw2-5hjv-9pf7

  2. Revision 1 · created ·

    Published from osv record GHSA-6pw2-5hjv-9pf7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-23555

Advisory: Sandbox bypass in vm2
IDs: CVE-2021-23555, GHSA-6pw2-5hjv-9pf7
Record: https://patchnext.com/advisories/cve-2021-23555 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.9.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected < 3.9.6; fixed in 3.9.6

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6pw2-5hjv-9pf7 (OSV record GHSA-6pw2-5hjv-9pf7 lists affected ranges: npm vm2 >=0 <3.9.6 (fixed))
- Verified: https://github.com/advisories/GHSA-6pw2-5hjv-9pf7 (GitHub-reviewed advisory GHSA-6pw2-5hjv-9pf7 lists affected ranges: npm vm2 >=0 <3.9.6)

Commands are suggestions: review each one before running it.

Loading voting…