Skip to content

← Actionable
Critical, CVSS 9.8amended

Exposure of Resource to Wrong Sphere in Zip-Local

CVE-2021-23484GHSA-wxj7-97fp-j53j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zip-local 0.3.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-23484: 2.05% estimated exploitation activity in the next 30 days; percentile 81.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The package zip-local before 0.3.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) which can lead to an extraction of a crafted file outside the intended extraction directory.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wxj7-97fp-j53j

  2. Revision 1 · created ·

    Published from osv record GHSA-wxj7-97fp-j53j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-23484

Advisory: Exposure of Resource to Wrong Sphere in Zip-Local
IDs: CVE-2021-23484, GHSA-wxj7-97fp-j53j
Record: https://patchnext.com/advisories/cve-2021-23484 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zip-local 0.3.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm zip-local: affected < 0.3.5; fixed in 0.3.5

## Suggested inspection (read-only)
- `npm ls zip-local --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zip-local.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wxj7-97fp-j53j (OSV record GHSA-wxj7-97fp-j53j lists affected ranges: npm zip-local >=0 <0.3.5 (fixed))
- Verified: https://github.com/advisories/GHSA-wxj7-97fp-j53j (GitHub-reviewed advisory GHSA-wxj7-97fp-j53j lists affected ranges: npm zip-local >=0 <0.3.5)

Commands are suggestions: review each one before running it.

Loading voting…