Skip to content

← Actionable
Medium, CVSS 5.4amended

Cross-site Scripting in edge.js

CVE-2021-23443GHSA-55r9-7mf8-m382

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (edge.js 5.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm edge.js

    Affected
    < 5.3.2
    Fixed in
    5.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2021-23443: 0.91% estimated exploitation activity in the next 30 days; percentile 59.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Edge is a logical and batteries included template engine for Node.js. This affects the package edge.js before 5.3.2. A type confusion vulnerability can be used to bypass input sanitization when the input to be rendered is an array (instead of a string or a SafeValue), even if {{ }} are used.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-55r9-7mf8-m382

  2. Revision 1 · created ·

    Published from osv record GHSA-55r9-7mf8-m382

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-23443

Advisory: Cross-site Scripting in edge.js
IDs: CVE-2021-23443, GHSA-55r9-7mf8-m382
Record: https://patchnext.com/advisories/cve-2021-23443 (revision 2, source checked 26 Oct 2026, 12:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: edge.js 5.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm edge.js: affected < 5.3.2; fixed in 5.3.2

## Suggested inspection (read-only)
- `npm ls edge.js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on edge.js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-55r9-7mf8-m382 (OSV record GHSA-55r9-7mf8-m382 lists affected ranges: npm edge.js >=0 <5.3.2 (fixed))
- Verified: https://github.com/advisories/GHSA-55r9-7mf8-m382 (GitHub-reviewed advisory GHSA-55r9-7mf8-m382 lists affected ranges: npm edge.js >=0 <5.3.2)

Commands are suggestions: review each one before running it.

Loading voting…