Prototype Pollution in set-value
CVE-2021-23440GHSA-4jqc-8m5r-9rpr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (set-value 4.0.1, 3.0.3, 2.0.1; set-value-nuget 2.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm set-value
- Affected
- < 2.0.1>= 4.0.0, < 4.0.1>= 3.0.0, < 3.0.3
- Fixed in
- 2.0.1, 3.0.3, 4.0.1
NuGet set-value-nuget
- Affected
- < 2.0.0
- Fixed in
- 2.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4jqc-8m5r-9rpr lists affected ranges: npm set-value >=4.0.0 =0 =3.0.0 =0 <2.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4jqc-8m5r-9rpr lists affected ranges: NuGet set-value-nuget >=0 =0 =4.0.0 =3.0.0 <3.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2021-23440: 2.21% estimated exploitation activity in the next 30 days; percentile 82.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package set-value. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4jqc-8m5r-9rpr
- Revision 1 · created ·
Published from osv record GHSA-4jqc-8m5r-9rpr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23440 Advisory: Prototype Pollution in set-value IDs: CVE-2021-23440, GHSA-4jqc-8m5r-9rpr Record: https://patchnext.com/advisories/cve-2021-23440 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: set-value 4.0.1, 3.0.3, 2.0.1; set-value-nuget 2.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm set-value: affected < 2.0.1; >= 4.0.0, < 4.0.1; >= 3.0.0, < 3.0.3; fixed in 2.0.1, 3.0.3, 4.0.1 - NuGet set-value-nuget: affected < 2.0.0; fixed in 2.0.0 ## Suggested inspection (read-only) - `npm ls set-value --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - NuGet set-value-nuget: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on set-value, set-value-nuget. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4jqc-8m5r-9rpr (OSV record GHSA-4jqc-8m5r-9rpr lists affected ranges: npm set-value >=4.0.0 =0 =3.0.0 =0 <2.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4jqc-8m5r-9rpr (GitHub-reviewed advisory GHSA-4jqc-8m5r-9rpr lists affected ranges: NuGet set-value-nuget >=0 =0 =4.0.0 =3.0.0 <3.0.3) Commands are suggestions: review each one before running it.
Loading voting…