Prototype Pollution in immer
CVE-2021-23436GHSA-33f9-j839-rf8h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (immer 9.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm immer
- Affected
- >= 7.0.0, < 9.0.6
- Fixed in
- 9.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-33f9-j839-rf8h lists affected ranges: npm immer >=7.0.0 <9.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-33f9-j839-rf8h lists affected ranges: npm immer >=7.0.0 <9.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-23436: 1.80% estimated exploitation activity in the next 30 days; percentile 78.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package immer before 9.0.6. A type confusion vulnerability can lead to a bypass of CVE-2020-28477 when the user-provided keys used in the path parameter are arrays. In particular, this bypass is possible because the condition (p === "proto" || p === "constructor") in applyPatches returns false if p is ['proto'] (or ['constructor']). The === operator (strict equality operator) returns false if the operands have different type.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-33f9-j839-rf8h
- Revision 1 · created ·
Published from osv record GHSA-33f9-j839-rf8h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23436 Advisory: Prototype Pollution in immer IDs: CVE-2021-23436, GHSA-33f9-j839-rf8h Record: https://patchnext.com/advisories/cve-2021-23436 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: immer 9.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm immer: affected >= 7.0.0, < 9.0.6; fixed in 9.0.6 ## Suggested inspection (read-only) - `npm ls immer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on immer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-33f9-j839-rf8h (OSV record GHSA-33f9-j839-rf8h lists affected ranges: npm immer >=7.0.0 <9.0.6 (fixed)) - Verified: https://github.com/advisories/GHSA-33f9-j839-rf8h (GitHub-reviewed advisory GHSA-33f9-j839-rf8h lists affected ranges: npm immer >=7.0.0 <9.0.6) Commands are suggestions: review each one before running it.
Loading voting…