Clearance Gem Open Redirect Vulnerability
CVE-2021-23435GHSA-4hpq-rjcx-7vj9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (clearance 2.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems clearance
- Affected
- < 2.5.0
- Fixed in
- 2.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4hpq-rjcx-7vj9 lists affected ranges: RubyGems clearance >=0 <2.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H
- EPSS
- CVE-2021-23435: 0.70% estimated exploitation activity in the next 30 days; percentile 53.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package clearance before 2.5.0. The vulnerability can be possible when users are able to set the value of session[:returnto]. If the value used for returnto contains multiple leading slashes (/////example.com) the user ends up being redirected to the external domain that comes after the slashes (http://example.com).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4hpq-rjcx-7vj9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23435 Advisory: Clearance Gem Open Redirect Vulnerability IDs: CVE-2021-23435, GHSA-4hpq-rjcx-7vj9 Record: https://patchnext.com/advisories/cve-2021-23435 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: clearance 2.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems clearance: affected < 2.5.0; fixed in 2.5.0 ## Suggested inspection (read-only) - RubyGems clearance: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on clearance. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4hpq-rjcx-7vj9 (GitHub-reviewed advisory GHSA-4hpq-rjcx-7vj9 lists affected ranges: RubyGems clearance >=0 <2.5.0) Commands are suggestions: review each one before running it.
Loading voting…