Skip to content

← Actionable
Medium, CVSS 5.5amended

Path Traversal in bikshed

CVE-2021-23423GHSA-hf6p-4rv2-9qrp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bikeshed 3.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bikeshed

    Affected
    < 3.0.0
    Fixed in
    3.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2021-23423: 1.11% estimated exploitation activity in the next 30 days; percentile 65.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This affects the package bikeshed before 3.0.0. This can occur when an untrusted source file containing include, include-code or include-raw block is processed. The contents of arbitrary files could be disclosed in the HTML output.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hf6p-4rv2-9qrp

  2. Revision 1 · created ·

    Published from osv record GHSA-hf6p-4rv2-9qrp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-23423

Advisory: Path Traversal in bikshed
IDs: CVE-2021-23423, GHSA-hf6p-4rv2-9qrp
Record: https://patchnext.com/advisories/cve-2021-23423 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bikeshed 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bikeshed: affected < 3.0.0; fixed in 3.0.0

## Suggested inspection (read-only)
- `python -m pip show bikeshed`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bikeshed.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hf6p-4rv2-9qrp (OSV record GHSA-hf6p-4rv2-9qrp lists affected ranges: PyPI bikeshed >=0 <3.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hf6p-4rv2-9qrp (GitHub-reviewed advisory GHSA-hf6p-4rv2-9qrp lists affected ranges: PyPI bikeshed >=0 <3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…