Skip to content

← Actionable
Critical, CVSS 9.8

Deserialization of Untrusted Data in codeception/codeception

CVE-2021-23420GHSA-4574-qv3w-fcmg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (codeception/codeception 4.1.22, 3.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-23420: 2.71% estimated exploitation activity in the next 30 days; percentile 86.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This affects the package codeception/codeception from 4.0.0 before 4.1.22 and before 3.1.3. The RunProcess class can be leveraged as a gadget to run arbitrary commands on a system that is deserializing user input without validation.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4574-qv3w-fcmg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-23420

Advisory: Deserialization of Untrusted Data in codeception/codeception
IDs: CVE-2021-23420, GHSA-4574-qv3w-fcmg
Record: https://patchnext.com/advisories/cve-2021-23420 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: codeception/codeception 4.1.22, 3.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist codeception/codeception: affected >= 4.0.0, < 4.1.22; < 3.1.3; fixed in 3.1.3, 4.1.22

## Suggested inspection (read-only)
- Packagist codeception/codeception: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on codeception/codeception.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4574-qv3w-fcmg (GitHub-reviewed advisory GHSA-4574-qv3w-fcmg lists affected ranges: Packagist codeception/codeception >=4.0.0 =0 <3.1.3)

Commands are suggestions: review each one before running it.

Loading voting…