SQL injection in pimcore/pimcore
CVE-2021-23405GHSA-g8jx-66p8-vcm2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 10.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/pimcore
- Affected
- < 10.0.7
- Fixed in
- 10.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g8jx-66p8-vcm2 lists affected ranges: Packagist pimcore/pimcore >=0 <10.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-23405: 1.71% estimated exploitation activity in the next 30 days; percentile 77.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package pimcore/pimcore before 10.0.7. This issue exists due to the absence of check on the storeId parameter in the method collectionsActionGet and groupsActionGet method within the ClassificationstoreController class.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g8jx-66p8-vcm2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23405 Advisory: SQL injection in pimcore/pimcore IDs: CVE-2021-23405, GHSA-g8jx-66p8-vcm2 Record: https://patchnext.com/advisories/cve-2021-23405 (revision 1, source checked 26 Oct 2026, 14:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 10.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/pimcore: affected < 10.0.7; fixed in 10.0.7 ## Suggested inspection (read-only) - Packagist pimcore/pimcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/pimcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g8jx-66p8-vcm2 (GitHub-reviewed advisory GHSA-g8jx-66p8-vcm2 lists affected ranges: Packagist pimcore/pimcore >=0 <10.0.7) Commands are suggestions: review each one before running it.
Loading voting…