Open redirect in Flask-Unchained
CVE-2021-23393GHSA-pjc4-3w99-j7v4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-unchained 0.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI flask-unchained
- Affected
- < 0.9.0
- Fixed in
- 0.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pjc4-3w99-j7v4 lists affected ranges: PyPI flask-unchained >=0 <0.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pjc4-3w99-j7v4 lists affected ranges: PyPI flask-unchained >=0 <0.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-23393: 0.72% estimated exploitation activity in the next 30 days; percentile 53.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package Flask-Unchained before 0.9.0. When using the the validateredirecturl function, it is possible to bypass URL validation and redirect a user to an arbitrary URL by providing multiple back slashes such as \\\evil.com/path. This vulnerability is only exploitable if an alternative WSGI server other than Werkzeug is used, or the default behaviour of Werkzeug is modified using 'autocorrectlocationheader=False.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pjc4-3w99-j7v4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pjc4-3w99-j7v4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23393 Advisory: Open redirect in Flask-Unchained IDs: CVE-2021-23393, GHSA-pjc4-3w99-j7v4 Record: https://patchnext.com/advisories/cve-2021-23393 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flask-unchained 0.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI flask-unchained: affected < 0.9.0; fixed in 0.9.0 ## Suggested inspection (read-only) - `python -m pip show flask-unchained`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flask-unchained. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pjc4-3w99-j7v4 (OSV record GHSA-pjc4-3w99-j7v4 lists affected ranges: PyPI flask-unchained >=0 <0.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-pjc4-3w99-j7v4 (GitHub-reviewed advisory GHSA-pjc4-3w99-j7v4 lists affected ranges: PyPI flask-unchained >=0 <0.9.0) Commands are suggestions: review each one before running it.
Loading voting…