Skip to content

← Actionable
Critical, CVSS 9.8amended

Remote code execution in handlebars when compiling templates

CVE-2021-23369GHSA-f2jv-r9rf-7988

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.webjars.bowergithub.wycats:handlebars.js 4.7.7; handlebars 4.7.7; org.webjars.npm:handlebars 4.7.7; org.webjars:handlebars 4.7.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-23369: 7.03% estimated exploitation activity in the next 30 days; percentile 94.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The package handlebars before 4.7.7 are vulnerable to Remote Code Execution (RCE) when selecting certain compiling options to compile templates coming from an untrusted source.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f2jv-r9rf-7988

  2. Revision 1 · created ·

    Published from osv record GHSA-f2jv-r9rf-7988

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-23369

Advisory: Remote code execution in handlebars when compiling templates
IDs: CVE-2021-23369, GHSA-f2jv-r9rf-7988
Record: https://patchnext.com/advisories/cve-2021-23369 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.webjars.bowergithub.wycats:handlebars.js 4.7.7; handlebars 4.7.7; org.webjars.npm:handlebars 4.7.7; org.webjars:handlebars 4.7.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.webjars.bowergithub.wycats:handlebars.js: affected < 4.7.7; fixed in 4.7.7
- npm handlebars: affected < 4.7.7; fixed in 4.7.7
- Maven org.webjars.npm:handlebars: affected < 4.7.7; fixed in 4.7.7
- Maven org.webjars:handlebars: affected < 4.7.7; fixed in 4.7.7

## Suggested inspection (read-only)
- Maven org.webjars.bowergithub.wycats:handlebars.js: check the installed version with your package manager.
- `npm ls handlebars --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- Maven org.webjars.npm:handlebars: check the installed version with your package manager.
- Maven org.webjars:handlebars: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.webjars.bowergithub.wycats:handlebars.js, handlebars, org.webjars.npm:handlebars, org.webjars:handlebars.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f2jv-r9rf-7988 (OSV record GHSA-f2jv-r9rf-7988 lists affected ranges: npm handlebars >=0 =0 =0 =0 <4.7.7 (fixed))
- Verified: https://github.com/advisories/GHSA-f2jv-r9rf-7988 (GitHub-reviewed advisory GHSA-f2jv-r9rf-7988 lists affected ranges: npm handlebars >=0 =0 =0 =0 <4.7.7)

Commands are suggestions: review each one before running it.

Loading voting…