Skip to content

← Actionable
Medium, CVSS 6.4amended

Arbitrary Command Injection in portprocesses

CVE-2021-23348GHSA-vm67-7vmg-66vm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (portprocesses 1.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-23348: 1.82% estimated exploitation activity in the next 30 days; percentile 78.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An Arbitrary Command Injection vulnerability was reported in portprocesses impacting versions <= 1.0.4. Example (Proof of Concept) The following example demonstrates the vulnerability and will run touch success therefore creating a file named success.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vm67-7vmg-66vm

  2. Revision 1 · created ·

    Published from osv record GHSA-vm67-7vmg-66vm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-23348

Advisory: Arbitrary Command Injection in portprocesses
IDs: CVE-2021-23348, GHSA-vm67-7vmg-66vm
Record: https://patchnext.com/advisories/cve-2021-23348 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: portprocesses 1.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm portprocesses: affected < 1.0.5; fixed in 1.0.5

## Suggested inspection (read-only)
- `npm ls portprocesses --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on portprocesses.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vm67-7vmg-66vm (OSV record GHSA-vm67-7vmg-66vm lists affected ranges: npm portprocesses >=0 <1.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-vm67-7vmg-66vm (GitHub-reviewed advisory GHSA-vm67-7vmg-66vm lists affected ranges: npm portprocesses >=0 <1.0.5)

Commands are suggestions: review each one before running it.

Loading voting…