Possible XSS when using SSO with the CLI in github.com/argoproj/argo-cd/v2
CVE-2021-23347GHSA-qq5v-f4c3-395c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/argoproj/argo-cd/v2 1.8.6, 1.7.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/argoproj/argo-cd/v2
- Affected
- < 1.7.13>= 1.8.0, < 1.8.6
- Fixed in
- 1.8.6, 1.7.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qq5v-f4c3-395c lists affected ranges: Go github.com/argoproj/argo-cd/v2 >=0 =1.8.0 <1.8.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2021-23347: 0.59% estimated exploitation activity in the next 30 days; percentile 48.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When using SSO with the Argo CD CLI, a malicious SSO provider could have sent specially crafted error message that would result in XSS on the client by means of executing arbitrary JavaScript code. We believe the exploitation of this vulnerability is only be possible when Argo CD is connected to a compromised/malicious SSO provider. Patches A patch for this vulnerability is available with the v1.8.7 and v1.7.14 releases of Argo CD. Workarounds Do not use SSO with the CLI when you don't trust your SSO provider If you have any questions or comments about this advisory: Open an issue in the Argo CD issue tracker or discussions Join us on Slack in channel #argo-cd Credits The issue was found during static code scanning with CodeQL and fixed by the Argo CD team. While we believed that a rogue SSO provider would pose a severe threat by itself, we fixed it like a regular bug. The Argo CD team would like to thank Adam Gold of Snyk (https://snyk.io) for stepping up and classifying this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qq5v-f4c3-395c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23347 Advisory: Possible XSS when using SSO with the CLI in github.com/argoproj/argo-cd/v2 IDs: CVE-2021-23347, GHSA-qq5v-f4c3-395c Record: https://patchnext.com/advisories/cve-2021-23347 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/argoproj/argo-cd/v2 1.8.6, 1.7.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/argoproj/argo-cd/v2: affected < 1.7.13; >= 1.8.0, < 1.8.6; fixed in 1.8.6, 1.7.13 ## Suggested inspection (read-only) - Go github.com/argoproj/argo-cd/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/argoproj/argo-cd/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qq5v-f4c3-395c (GitHub-reviewed advisory GHSA-qq5v-f4c3-395c lists affected ranges: Go github.com/argoproj/argo-cd/v2 >=0 =1.8.0 <1.8.6) Commands are suggestions: review each one before running it.
Loading voting…