Command Injection in lodash
CVE-2021-23337GHSA-35jh-r3h4-6jhm
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm lodash.template
- Affected
- <= 4.5.0
- Fixed in
- no fixed version recorded
RubyGems lodash-rails
- Affected
- < 4.17.21
- Fixed in
- 4.17.21
npm lodash-es
- Affected
- < 4.17.21
- Fixed in
- 4.17.21
npm lodash
- Affected
- < 4.17.21
- Fixed in
- 4.17.21
npm lodash-template
- Affected
- <= 1.0.0
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-35jh-r3h4-6jhm lists affected ranges: npm lodash >=0 =0 =0 =0 =0 <4.17.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-35jh-r3h4-6jhm lists affected ranges: npm lodash >=0 =0 =0 =0 =0 <4.17.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-23337: 21.33% estimated exploitation activity in the next 30 days; percentile 97.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
lodash versions prior to 4.17.21 are vulnerable to Command Injection via the template function.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-35jh-r3h4-6jhm
- Revision 1 · created ·
Published from osv record GHSA-35jh-r3h4-6jhm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23337 Advisory: Command Injection in lodash IDs: CVE-2021-23337, GHSA-35jh-r3h4-6jhm Record: https://patchnext.com/advisories/cve-2021-23337 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: lodash-rails 4.17.21; lodash-es 4.17.21; lodash 4.17.21. A vendor fix does not mean a deployment is fixed. ## Affected components - npm lodash.template: affected <= 4.5.0 - RubyGems lodash-rails: affected < 4.17.21; fixed in 4.17.21 - npm lodash-es: affected < 4.17.21; fixed in 4.17.21 - npm lodash: affected < 4.17.21; fixed in 4.17.21 - npm lodash-template: affected <= 1.0.0 ## Suggested inspection (read-only) - `npm ls lodash.template --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - RubyGems lodash-rails: check the installed version with your package manager. - `npm ls lodash-es --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls lodash --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls lodash-template --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lodash.template, lodash-rails, lodash-es, lodash, lodash-template. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-35jh-r3h4-6jhm (OSV record GHSA-35jh-r3h4-6jhm lists affected ranges: npm lodash >=0 =0 =0 =0 =0 <4.17.21 (fixed)) - Verified: https://github.com/advisories/GHSA-35jh-r3h4-6jhm (GitHub-reviewed advisory GHSA-35jh-r3h4-6jhm lists affected ranges: npm lodash >=0 =0 =0 =0 =0 <4.17.21) Commands are suggestions: review each one before running it.
Loading voting…