XSS in apexcharts
CVE-2021-23327GHSA-w46j-8hm6-h8mm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apexcharts 3.24.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm apexcharts
- Affected
- < 3.24.0
- Fixed in
- 3.24.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w46j-8hm6-h8mm lists affected ranges: npm apexcharts >=0 <3.24.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w46j-8hm6-h8mm lists affected ranges: npm apexcharts >=0 <3.24.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2021-23327: 1.37% estimated exploitation activity in the next 30 days; percentile 71.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The package apexcharts before 3.24.0 are vulnerable to Cross-site Scripting (XSS) via lack of sanitization of graph legend fields.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w46j-8hm6-h8mm
- Revision 1 · created ·
Published from osv record GHSA-w46j-8hm6-h8mm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23327 Advisory: XSS in apexcharts IDs: CVE-2021-23327, GHSA-w46j-8hm6-h8mm Record: https://patchnext.com/advisories/cve-2021-23327 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apexcharts 3.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm apexcharts: affected < 3.24.0; fixed in 3.24.0 ## Suggested inspection (read-only) - `npm ls apexcharts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apexcharts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w46j-8hm6-h8mm (OSV record GHSA-w46j-8hm6-h8mm lists affected ranges: npm apexcharts >=0 <3.24.0 (fixed)) - Verified: https://github.com/advisories/GHSA-w46j-8hm6-h8mm (GitHub-reviewed advisory GHSA-w46j-8hm6-h8mm lists affected ranges: npm apexcharts >=0 <3.24.0) Commands are suggestions: review each one before running it.
Loading voting…