DOS and Open Redirect with user input
CVE-2021-22964GHSA-pgh6-m65r-2rhq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify-static 4.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fastify-static
- Affected
- >= 4.2.4, < 4.4.1
- Fixed in
- 4.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pgh6-m65r-2rhq lists affected ranges: npm fastify-static >=4.2.4 <4.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pgh6-m65r-2rhq lists affected ranges: npm fastify-static >=4.2.4 <4.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:H
- EPSS
- CVE-2021-22964: 1.02% estimated exploitation activity in the next 30 days; percentile 63.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A redirect vulnerability in the fastify-static module allows remote attackers to redirect Mozilla Firefox users to arbitrary websites via a double slash // followed by a domain: http://localhost:3000//a//youtube.com/%2e%2e%2f%2e%2e. A DOS vulnerability is possible if the URL contains invalid characters curl --path-as-is "http://localhost:3000//^/.." The issue shows up on all the fastify-static applications that set redirect: true option. By default, it is false. Patches The issue has been patched in fastify-static@4.4.1 Workarounds If updating is not an option, you can sanitize the input URLs using the rewriteUrl server option. References + Bug founder: drstrnegth + hackerone Report For more information If you have any questions or comments about this advisory: Open an issue in fastify-static Contact the security team
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pgh6-m65r-2rhq
- Revision 1 · created ·
Published from osv record GHSA-pgh6-m65r-2rhq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-22964 Advisory: DOS and Open Redirect with user input IDs: CVE-2021-22964, GHSA-pgh6-m65r-2rhq Record: https://patchnext.com/advisories/cve-2021-22964 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fastify-static 4.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fastify-static: affected >= 4.2.4, < 4.4.1; fixed in 4.4.1 ## Suggested inspection (read-only) - `npm ls fastify-static --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastify-static. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pgh6-m65r-2rhq (OSV record GHSA-pgh6-m65r-2rhq lists affected ranges: npm fastify-static >=4.2.4 <4.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-pgh6-m65r-2rhq (GitHub-reviewed advisory GHSA-pgh6-m65r-2rhq lists affected ranges: npm fastify-static >=4.2.4 <4.4.1) Commands are suggestions: review each one before running it.
Loading voting…