Skip to content

← Actionable
Unrated

Password exposure in concrete5/core

CVE-2021-22951GHSA-rhf5-f553-xg82

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (concrete5/core 8.5.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2021-22951: 1.11% estimated exploitation activity in the next 30 days; percentile 65.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unauthorized individuals could view password protected files using viewinline in Concrete CMS (previously concrete 5) prior to version 8.5.7. Concrete CMS now checks to see if a file has a password in viewinline and, if it does, the file is not rendered.For version 8.5.6, the following mitigations were put in place a. restricting file types for viewinline to images only b. putting a warning in the file manager to advise users.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rhf5-f553-xg82

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-22951

Advisory: Password exposure in concrete5/core
IDs: CVE-2021-22951, GHSA-rhf5-f553-xg82
Record: https://patchnext.com/advisories/cve-2021-22951 (revision 1, source checked 26 Oct 2026, 14:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: concrete5/core 8.5.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist concrete5/core: affected < 8.5.7; fixed in 8.5.7

## Suggested inspection (read-only)
- Packagist concrete5/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on concrete5/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rhf5-f553-xg82 (GitHub-reviewed advisory GHSA-rhf5-f553-xg82 lists affected ranges: Packagist concrete5/core >=0 <8.5.7)

Commands are suggestions: review each one before running it.

Loading voting…