Skip to content

← Actionable
Unrated

Node.js before is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior. You can read more about it in…

CVE-2021-22930

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 16.6.0, 14.17.4, 12.22.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • runtime node

    Affected
    >= 12.0.0, < 12.22.4>= 14.0.0, < 14.17.4>= 16.0.0, < 16.6.0
    Fixed in
    12.22.4, 16.6.0, 14.17.4

Sources

  • raw.githubusercontent.com runtime security intelligence

    Node.js security working group core entry 79 lists CVE-2021-22930 affecting node >=12.0.0 =14.0.0 =16.0.0 <16.6.0

    VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.

  • nodejs.org runtime security intelligence

    The nodejs.org release index dates the first patched release for CVE-2021-22930 to 2021-07-29.

    VerifiedObserved Official nodejs.org release index (dist/index.json).

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2021-22930: 36.45% estimated exploitation activity in the next 30 days; percentile 98.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Node.js before is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior. You can read more about it in https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-22930

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · published ·

    Published from vendor_advisory record nodejs-security-wg:core:79

  2. Revision 1 · created ·

    Created from vendor_advisory record nodejs-security-wg:core:79

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-22930

Advisory: Node.js before is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior. You can read more about it in…
IDs: CVE-2021-22930
Record: https://patchnext.com/advisories/cve-2021-22930 (revision 2, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node 16.6.0, 14.17.4, 12.22.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- runtime node: affected >= 12.0.0, < 12.22.4; >= 14.0.0, < 14.17.4; >= 16.0.0, < 16.6.0; fixed in 12.22.4, 16.6.0, 14.17.4

## Suggested inspection (read-only)
- runtime node: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/79.json (Node.js security working group core entry 79 lists CVE-2021-22930 affecting node >=12.0.0 =14.0.0 =16.0.0 <16.6.0)
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2021-22930 to 2021-07-29.)

Commands are suggestions: review each one before running it.

Loading voting…