Actionpack Open Redirect Vulnerability
CVE-2021-22881GHSA-8877-prq4-9xfw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionpack 6.1.2.1, 6.0.3.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems actionpack
- Affected
- >= 6.0.0, <= 6.0.3.4>= 6.1.0, <= 6.1.2.0
- Fixed in
- 6.0.3.5, 6.1.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8877-prq4-9xfw lists affected ranges: RubyGems actionpack >=6.0.0 =6.1.0 <=6.1.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-22881: 87.30% estimated exploitation activity in the next 30 days; percentile 99.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Host Authorization middleware in Action Pack before 6.1.2.1, 6.0.3.5 suffers from an open redirect vulnerability. Specially crafted Host headers in combination with certain "allowed host" formats can cause the Host Authorization middleware in Action Pack to redirect users to a malicious website.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8877-prq4-9xfw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-22881 Advisory: Actionpack Open Redirect Vulnerability IDs: CVE-2021-22881, GHSA-8877-prq4-9xfw Record: https://patchnext.com/advisories/cve-2021-22881 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: actionpack 6.1.2.1, 6.0.3.5. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems actionpack: affected >= 6.0.0, <= 6.0.3.4; >= 6.1.0, <= 6.1.2.0; fixed in 6.0.3.5, 6.1.2.1 ## Suggested inspection (read-only) - RubyGems actionpack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on actionpack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8877-prq4-9xfw (GitHub-reviewed advisory GHSA-8877-prq4-9xfw lists affected ranges: RubyGems actionpack >=6.0.0 =6.1.0 <=6.1.2.0) Commands are suggestions: review each one before running it.
Loading voting…