Skip to content

← Actionable
High, CVSS 7.5

A potential Denial of Service issue in protobuf-java

CVE-2021-22569GHSA-wrvw-hg22-4m67

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.google.protobuf:protobuf-kotlin 3.19.2, 3.18.2; com.google.protobuf:protobuf-java 3.19.2, 3.18.2, 3.16.1; google-protobuf 3.19.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-wrvw-hg22-4m67 lists affected ranges: Maven com.google.protobuf:protobuf-java >=0 =3.18.0 =3.19.0 =0 =3.18.0 =3.19.0 <3.19.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-22569: 1.80% estimated exploitation activity in the next 30 days; percentile 78.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A potential Denial of Service issue in protobuf-java was discovered in the parsing procedure for binary data. Reporter: OSS-Fuzz Affected versions: All versions of Java Protobufs (including Kotlin and JRuby) prior to the versions listed below. Protobuf "javalite" users (typically Android) are not affected. Severity CVE-2021-22569 High - CVSS Score: 7.5, An implementation weakness in how unknown fields are parsed in Java. A small (~800 KB) malicious payload can occupy the parser for several minutes by creating large numbers of short-lived objects that cause frequent, repeated GC pauses. Proof of Concept For reproduction details, please refer to the oss-fuzz issue that identifies the specific inputs that exercise this parsing weakness. Remediation and Mitigation Please update to the latest available versions of the following packages: - protobuf-java (3.16.1, 3.18.2, 3.19.2) - protobuf-kotlin (3.18.2, 3.19.2) - google-protobuf [JRuby gem only] (3.19.2)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wrvw-hg22-4m67

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-22569

Advisory: A potential Denial of Service issue in protobuf-java
IDs: CVE-2021-22569, GHSA-wrvw-hg22-4m67
Record: https://patchnext.com/advisories/cve-2021-22569 (revision 1, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.google.protobuf:protobuf-kotlin 3.19.2, 3.18.2; com.google.protobuf:protobuf-java 3.19.2, 3.18.2, 3.16.1; google-protobuf 3.19.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.google.protobuf:protobuf-kotlin: affected >= 3.18.0, < 3.18.2; >= 3.19.0, < 3.19.2; fixed in 3.19.2, 3.18.2
- Maven com.google.protobuf:protobuf-java: affected < 3.16.1; >= 3.18.0, < 3.18.2; >= 3.19.0, < 3.19.2; fixed in 3.19.2, 3.18.2, 3.16.1
- RubyGems google-protobuf: affected < 3.19.2; fixed in 3.19.2

## Suggested inspection (read-only)
- Maven com.google.protobuf:protobuf-kotlin: check the installed version with your package manager.
- Maven com.google.protobuf:protobuf-java: check the installed version with your package manager.
- RubyGems google-protobuf: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.google.protobuf:protobuf-kotlin, com.google.protobuf:protobuf-java, google-protobuf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wrvw-hg22-4m67 (GitHub-reviewed advisory GHSA-wrvw-hg22-4m67 lists affected ranges: Maven com.google.protobuf:protobuf-java >=0 =3.18.0 =3.19.0 =0 =3.18.0 =3.19.0 <3.19.2)

Commands are suggestions: review each one before running it.

Loading voting…