Skip to content

← Actionable
Medium, CVSS 6.5

Insufficient Granularity of Access Control in github.com/google/exposure-notifications-verification-server

CVE-2021-22565GHSA-wx8q-rgfr-cf6v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/google/exposure-notifications-verification-server 1.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
EPSS
  • CVE-2021-22565: 0.44% estimated exploitation activity in the next 30 days; percentile 38.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users or API keys with permission to expire verification codes could have expired codes that belonged to another realm if they guessed the UUID. Patches v1.1.2+ Workarounds There are no workarounds, and there are no indications this has been exploited in the wild. Verification codes can only be expired by providing their 64-bit UUID, and verification codes are already valid for a very short period of time (thus the UUID rotates frequently). For more information Contact exposure-notifications-feedback@google.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wx8q-rgfr-cf6v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-22565

Advisory: Insufficient Granularity of Access Control in github.com/google/exposure-notifications-verification-server
IDs: CVE-2021-22565, GHSA-wx8q-rgfr-cf6v
Record: https://patchnext.com/advisories/cve-2021-22565 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/google/exposure-notifications-verification-server 1.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/google/exposure-notifications-verification-server: affected < 1.1.2; fixed in 1.1.2

## Suggested inspection (read-only)
- Go github.com/google/exposure-notifications-verification-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/google/exposure-notifications-verification-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wx8q-rgfr-cf6v (GitHub-reviewed advisory GHSA-wx8q-rgfr-cf6v lists affected ranges: Go github.com/google/exposure-notifications-verification-server >=0 <1.1.2)

Commands are suggestions: review each one before running it.

Loading voting…