Resource Exhaustion in Spring Security
CVE-2021-22119GHSA-w9jg-gvgr-354m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-core 5.5.1, 5.4.7, 5.3.10, 5.2.11; org.springframework.security:spring-security-oauth2-client 5.5.1, 5.4.7, 5.3.10, 5.2.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.security:spring-security-core
- Affected
- >= 5.5.0, < 5.5.1>= 5.4.0, < 5.4.7>= 5.3.0, <= 5.3.9>= 5.2.0, <= 5.2.10
- Fixed in
- 5.5.1, 5.3.10, 5.2.11, 5.4.7
Maven org.springframework.security:spring-security-oauth2-client
- Affected
- >= 5.5.0, < 5.5.1>= 5.4.0, < 5.4.7>= 5.3.0, <= 5.3.9>= 5.2.0, <= 5.2.10
- Fixed in
- 5.5.1, 5.3.10, 5.2.11, 5.4.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w9jg-gvgr-354m lists affected ranges: Maven org.springframework.security:spring-security-core >=5.5.0 =5.4.0 =5.3.0 =5.2.0 =5.5.0 =5.4.0 =5.3.0 =5.2.0 <=5.2.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-22119: 6.00% estimated exploitation activity in the next 30 days; percentile 93.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Spring Security versions 5.5.x prior to 5.5.1, 5.4.x prior to 5.4.7, 5.3.x prior to 5.3.10 and 5.2.x prior to 5.2.11 are susceptible to a Denial-of-Service (DoS) attack via the initiation of the Authorization Request in an OAuth 2.0 Client Web and WebFlux application. A malicious user or attacker can send multiple requests initiating the Authorization Request for the Authorization Code Grant, which has the potential of exhausting system resources using a single session or multiple sessions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w9jg-gvgr-354m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-22119 Advisory: Resource Exhaustion in Spring Security IDs: CVE-2021-22119, GHSA-w9jg-gvgr-354m Record: https://patchnext.com/advisories/cve-2021-22119 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-core 5.5.1, 5.4.7, 5.3.10, 5.2.11; org.springframework.security:spring-security-oauth2-client 5.5.1, 5.4.7, 5.3.10, 5.2.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.security:spring-security-core: affected >= 5.5.0, < 5.5.1; >= 5.4.0, < 5.4.7; >= 5.3.0, <= 5.3.9; >= 5.2.0, <= 5.2.10; fixed in 5.5.1, 5.3.10, 5.2.11, 5.4.7 - Maven org.springframework.security:spring-security-oauth2-client: affected >= 5.5.0, < 5.5.1; >= 5.4.0, < 5.4.7; >= 5.3.0, <= 5.3.9; >= 5.2.0, <= 5.2.10; fixed in 5.5.1, 5.3.10, 5.2.11, 5.4.7 ## Suggested inspection (read-only) - Maven org.springframework.security:spring-security-core: check the installed version with your package manager. - Maven org.springframework.security:spring-security-oauth2-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.security:spring-security-core, org.springframework.security:spring-security-oauth2-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w9jg-gvgr-354m (GitHub-reviewed advisory GHSA-w9jg-gvgr-354m lists affected ranges: Maven org.springframework.security:spring-security-core >=5.5.0 =5.4.0 =5.3.0 =5.2.0 =5.5.0 =5.4.0 =5.3.0 =5.2.0 <=5.2.10) Commands are suggestions: review each one before running it.
Loading voting…